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0.1 Introduction

GaMField is a suite of interacting WINDOWS modules that include A)

GaMField with a graphical user interface (GUI) for gravity and mag-

netic anomaly modeling of prisms, B) ModelBuilder for constructing 3D

anomalous sources of prisms, and C) FieldViewer for visualizing the 3D

models, as well as the related anomaly effects in map and profile formats

(Pignatelli et al., 2011).

0.2 Installation

The 32-bit or 64-bit versions of GaMField maintained by the Istituto

Nazionale di Geofisica e Vulcanologia (INGV) in Rome, Italy can be down-

loaded from⇒ geosoftware.sci.ingv.it upon registration.

Once downloaded from the INGV website, the user then must extract the

appropriate archive [i.e., GaMField32Bit.zip or GaMField64Bit.zip]

into a single folder with a path name containing no spaces [e.g., Gam-

Field32Bit 15Apr13 or GaMField64Bit 15Apr13 ].

When unzipped or extracted, the user clicks → GaMFieldInstaller.exe

to continue installing GaMField onto the user’s machine. This operation

brings up a DOS command window that installs the MATLAB runtime rou-

tines which allow the user’s machine to run the MATLAB codes in GaM-

Field . The DOS window may take a few minutes to come up and complete

the one-time installation of the MATLAB runtime routines. The user must

stroke the y-key followed by the Enter-key on the keyboard to the few

questions that appear as the installation of the runtime routines proceeds.

Thereafter, the user returns to the folder and clicks→ GaMField.exe

to start the program for any anomaly modeling application. This operation

generates the main program window shown in Figure 0.1, which may take

up to a few minutes to appear depending on the computer’s operating system

and speed.

0.3 Operations

A flowchart outlining the general functions of GaMField is given in Figure

0.2.

0.3.1 DEFINE/SAVE SURVEY AND SOURCE GRIDS

GaMField requires the user to specify first the horizontal boundaries, al-

titude, and other parameters for the 2D Observation Grid , and next the
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Figure 0.1 Main program window for the Gravity and M agnetic anomaly
Field modeling program GaMField .

horizontal and vertical boundaries and other parameters of the 3D Source

Grid [see Figure 0.1]. The additional parameters to be specified include

the intervals along the two horizontal axes of the Observation Grid and

the three axes of the Source Grid . All linear parameters are defined in me-

ters, with altitudes above and below sea level input as negative and positive

values, respectively.

For total magnetic field calculations, the uniform geomagnetic field incli-

nation and declination in degrees assumed for the observation grid is also

included.

Whenever the parameters of either an observation grid or source grid are

selected, the user must click→ Confirm Parameters to check the integrity

and completeness of the data inputs, and continue with the GaMField

operations.

At this point, the user may save the data inputs for later recall according

to the following options:

• Clicking→ File→ Survey Parameters→ Save saves the observation

and source grid parameters as a .txt file.
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Figure 0.2 Flowchart generalizing the basic operations of GaMField .

• Clicking→ File→ Model Parameters→ Save saves the model param-

eters as a .txt file.

• Clicking→ File→ Total Parameters→ Save saves the observation and

source grid parameters and the model parameters as a .txt file.

A flowchart outlining the setting and saving of observation and source

grid parameters for GaMField is given in Figure 0.3.

0.3.2 DEFINE ANOMALY COMPUTATIONS

At this point, the user may specify the anomaly modeling computions desired

from GaMField as outlined by the flowchart in Figure 0.4. For example,

the Compute Gradients button must be toggled on if the anomaly gra-

dients are desired in addition to the anomaly field; otherwise, the botton

must be toggled off to minimize the CPU time and effort in computing the

anomaly field.

The gradients are computed numerically, and thus when the Compute

Gradients button is toggled on , a spatial interval or step for the derivative

computations must be specified in a pop-up window that appears with the

selection of any of the five options in the Compute menu or any of the three
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Figure 0.3 Flowchart for setting and saving the observation and source grid
parameters in GaMField .
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Figure 0.4 Flowchart for defining the anomaly modeling computation in
GaMField .

compute-options in the Topography menu. The rule-of-thumb for effective

gradient estimates is to set this step at 10% or smaller of the depth to the

top of the source.
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Figure 0.5 Flowchart to load a DEM for modeling the magnetic and gravity
effects of topography.

Two anomaly field modeling options are available to the user from GaM-

Field at this point. The user may model the topographic effects from a

user-supplied digital elevation model (DEM) or model the effects of a 3D dis-

tribution of simple prisms, either user-supplied or interactively constructed

from the ModelBuilder module.

0.3.3 MODEL TOPOGRAPHIC EFFECTS

Figure 0.5 gives a flowchart for modeling the magnetic and gravity effects

of topography. In the GaMField window,

• clicking → Topography→ Load Topographic Model

allows the user to submit a digital elevation model (DEM) as a plain .txt

file in the following comma-separated format of up to 7 columns⇒ [Easting-

coordinate, Northing-coordinate, Top-elevation, Bottom-elevation, Density

(in g/cm3)/Magnetization Intensity (in A/m), Magnetization Inclination

(in degrees), Magnetization Declination (in degrees)].

Anomaly modeling options are selected as follows:
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Figure 0.6 Flowchart for modeling the effects of a 3D source made up of
simple prisms.

• To model the magnetic effects of the DEM, click→ Topography→ Com-

pute Topographic Magnetic Effects. If the anomaly gradients are also

desired, the user must have toggled the Compute Gradients button on

prior to selecting this field option.

• To model the gravity effects of the DEM, click→ Topography→ Com-

pute Topographic Gravity Effects. If the anomaly gradients are also

desired, the user must have toggled the Compute Gradients button on

prior to selecting this field option.

• To compute the selected effects along a profile taken interactively from the

anomaly map with mouse clicks indicating the starting and ending points,

click → Topography→ Compute a profile on topographic field . The

user also must specify the uniform interval of the desired observation

points along the profile.

0.3.4 MODEL SIMPLE PRISM EFFECTS

Figure 0.6 outlines the procedures for modeling the gravity and magnetic

effects for a 3D source of simple prisms. The 3D source can be loaded from

memory by

• clicking→ File→ Model→ Load Model
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Figure 0.7 Screen plot of the ModelBuilder GUI for constructing 3D
gravity and magnetic anomaly sources in GaMField .

or interactively constructed from simple prisms by

• clicking→ File→ Model→ Build Model ,

which opens the window with the stylized 3D perspective view of the source

region shown in Figure 0.7. The parameters of the simple prism model can

be saved to a .txt file at any stage of development for further development

and recall to subsequent applications by

• clicking→ File→ Model Parameters→ Save .

Each prism specified by the user has its top on a plane with its horizontal

boundaries defined by the North Interval and East Interval values of the

Source Grid menu of the main program window [Figure 0.1].

• For magnetic modeling, input the magnetization intensity in Amperes/meter

into the Magnetization (A/m)/Density (g/c.c.) field and the appropriate

degree values into the underlying Inclination and Declination fields.

• For gravity modeling, input the density in grams/cubic centimeter into

the Magnetization (A/m)/Density (g/c.c.) field.

• Select the layer to edit by selecting its depth from the Depth field. This

procedure brings up the window shown in Figure 0.8.
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Figure 0.8 Clicking activates the prism beneath the cross-hairs with the
selected physical properties. Clicking on an activated prism de-activates it.

• Placing the cross-hairs on a cell and clicking activates the underlying prism

with the previously selected physical properties. Clicking on an activated

cell de-activates it.

• When all the desired cells for the layer have been activated, the user

must press the Enter-key on the keyboard to store the selected prisms

and their physical properties for further processing.

• The user is then returned to the Build Model window [Figure 0.7] to

construct additional prisms at other depths and/or with other physical

properties.

TheBuild Model window [Figure 0.7] contains additional tools to speed

up the model building, which include:

• Clicking→ Polygon in the Selection Mode field allows the user to draw

a general polygon with mouse clicks onto the layer window [Figure 0.8]

to activate all prisms within the polygon when the Enter-key is pressed.

• Clicking→ Multiple Layer Copy allows the user to copy the prisms

from one layer to one or more other layers. It is done by clicking on the
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Figure 0.9 Screen plot of the perspective view of the prisms defining the
three-dimensional sources in the ascii file Ex1 model.txt in the Exam-
pleFiles sub-folder of the extracted GaMField folder [e.g., the GaM-
Field32Bit 15Apr13 folder] . Placing the mouse’s pointer on the image
and moving it about while holding the left button down changes the 3D
perspective view of the prisms.

button and following the program requests. Note that this button is absent

if the source grid has no activated cells.

• Clicking→ Show 3-D Model allows the user to visualize the model from

various perspectives in three-dimensions as illustrated by the example in

Figure 0.9.

When a satisfactory volumetric distribution of prisms is established, the

source model can be saved or recovered in one or more of the following ways:

• Clicking→ Save Builder Model allows the user to save the model
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in MATLAB’s .mat binary file format that can be loaded directly into

the ModelBuilder module. This option is useful for saving intermittent

model files during the construction of complex models.

• Clicking→ Load Builder Model allows the user to load the saved .mat

model file directly into the ModelBuilder module.

• Clicking→ Save Model For GaMField allows the user to save the

model parameters in the plain text .txt format that can be read by the

main GaMField module [Figure 0.1] for further processing.

• Clicking→ Send Model To GaMField submits the model directly to

the main GaMField module [Figure 0.1] for immediate anomaly com-

putations.

The anomaly computations may be selected according to the following

options:

• Clicking→ Compute→ Gravimetric Field or → Compute→ Mag-

netic Field computes the respective gravity and magnetic effects of

the subsurface model. If the anomaly gradients are also desired, the user

must have toggled theCompute Gradients button on prior to selecting

either of these two field options.

• Clicking→ Compute→ Multilevel Gravimetric Field or→ Compute→

Multilevel Gravimetric Field allows the user to generate the related

effects over a range of altitudes at a user-specified altitude-interval. If

the anomaly gradients are also desired, the user must have toggled the

Compute Gradients button on prior to selecting this option.

• Clicking→ Compute→ Profile On Map allows the user to compute

the effects along a profile taken interactively from the anomaly map with

mouse clicks indicating the starting and ending points. The user also must

specify the observation point interval along the profile.

In addition, before the anomaly computation starts, GaMField displays

the 3D image of the source and asks if the user wishes to specify the obser-

vation points rather than use the default input Observation Grid points. In

this case, the user can load the observation points as an ascii file of three

columns separated by commas giving the spatial coordinates in the following

format⇒ (Easting, Northing, Altitude)-coordinates.

0.3.5 VISUALIZATION OF RESULTS

The View menu in the main GaMField window [Figure 0.1] displays the

DEM and simple prism model, as well as their gravity and magnetic effects

according to the following options:
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Figure 0.10 Screen plot of the total magnetic field effects of the 3D
prisms in Figure 0.9 computed from the associated source model in ascii
file Ex1 model.txt as listed in the anomaly field values of the ascii file
Ex1 fields.txt, which are both located in the ExampleFiles sub-folder
of the extracted GaMField folder [e.g., the GaMField32Bit 15Apr13
folder] .

• Clicking→ View→ Built Model in the GaMField window provides a

3D image of the model that can be interactively viewed from different

perspectives as shown by the example in Figure 0.9.

• Clicking→ View→ DEM provides an interactive 3D image of the topo-

graphic DEM.

• Clicking→ View→ Complete Model Effects provides color-filled maps

and related statistics of the gravity or magnetic effects of the built model

including any specified gradient components. For the souce model of Fig-

ure 0.9, the related magnetic and gravity anomaly fields are shown in

Figures 0.10 and 0.11, respectively.
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Figure 0.11 Screen plot of the gravity field effects of the 3D prisms
in Figure 0.9 computed from the associated source model in ascii
file Ex1 model.txt as listed in the anomaly field values of the ascii file
Ex1 fields.txt, which are both located in the ExampleFiles sub-folder
of the extracted GaMField folder [e.g., the GaMField32Bit 15Apr13
folder] .

• Clicking→ View→ Complete DEM Effects provides color-filled maps

and related statistics of the gravity or magnetic effects of the DEM in-

cluding any specified gradient components.

• Clicking→ Close All Figures in the GaMField window closes all the

figures.

• Clicking→ Clear All Models in the GaMField window cleans the

memory of all the built and loaded models
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0.4 Conclusions

GaMField is a MATLAB-based geopotential field generator that constructs

and visualizes topographic and subsurface sources in 3D space and com-

putes their gravity and magnetic effects. GaMField also computes anomaly

gradients and remanent magnetization effects. The user inputs Cartesian

prisms along with their physical properties to fabricate the topographic or

subsurface sources in an interactive WINDOWS environment. The Exam-

pleFiles sub-folder of the extracted GaMField folder [e.g., the GaM-

Field32Bit 15Apr13 folder] contains file examples for loading and mod-

eling the magnetic and gravity effects of a subsurface distribution of simple

prisms, and a DEM of the Tenerife volcano in the Canary Islands off the

Atlantic coast of Spain.

GaMField and its periodic updates can be freely downloaded from the

website given in Section 0.2-above that the INGV operates as a public

service. The website also entertains questions and recommendations from

users for implementing and improving GaMField .
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